Building problem

Nov 29, 2014 at 9:45 AM
Hi, Tnhks for project.

i try build a project but return this errors:

BUILD: [04:0000000146:ERRORE] Error(s) in directory "C:\WINCE700\platform\raspi2\src\MyKitlCore\". {log="C:\WINCE700\build.log(33744)"}
BUILD: [04:0000000147:ERRORE] c:\wince700\platform\raspi2\src\mykitlcore\ethdbg.c(48) : fatal error C1083: Cannot open include file: 'kernel.h': No such file or directory {log="C:\WINCE700\build.log(33745)"}
BUILD: [04:0000000154:ERRORE] c:\wince700\platform\raspi2\src\mykitlcore\edbgprot.c(37) : fatal error C1083: Cannot open include file: 'kernel.h': No such file or directory {log="C:\WINCE700\build.log(33752)"}
BUILD: [04:0000000162:ERRORE] c:\wince700\platform\raspi2\src\mykitlcore\timer.c(39) : fatal error C1083: Cannot open include file: 'kernel.h': No such file or directory {log="C:\WINCE700\build.log(33760)"}
BUILD: [04:0000000164:ERRORE] c:\wince700\platform\raspi2\src\mykitlcore\kitladmin.c(16) : fatal error C1083: Cannot open include file: 'kernel.h': No such file or directory {log="C:\WINCE700\build.log(33762)"}
BUILD: [04:0000000168:ERRORE] c:\wince700\platform\raspi2\src\mykitlcore\kitlsend.c(16) : fatal error C1083: Cannot open include file: 'kernel.h': No such file or directory {log="C:\WINCE700\build.log(33766)"}
BUILD: [04:0000000170:ERRORE] c:\wince700\platform\raspi2\src\mykitlcore\kitlrecv.c(16) : fatal error C1083: Cannot open include file: 'kernel.h': No such file or directory {log="C:\WINCE700\build.log(33768)"}
BUILD: [04:0000000173:ERRORE] c:\wince700\platform\raspi2\src\mykitlcore\kitltran.c(16) : fatal error C1083: Cannot open include file: 'kernel.h': No such file or directory {log="C:\WINCE700\build.log(33771)"}
BUILD: [04:0000000176:ERRORE] c:\wince700\platform\raspi2\src\mykitlcore\debug.c(34) : fatal error C1083: Cannot open include file: 'kernel.h': No such file or directory {log="C:\WINCE700\build.log(33774)"}
BUILD: [04:0000000179:ERRORE] NMAKE : fatal error U1077: 'C:\WINCE700\sdk\bin\i386\ARM\cl.EXE' : return code '0x2' {log="C:\WINCE700\build.log(33777)"}
BUILD: [04:0000000181:ERRORE] clean TargetCompilePass -nologo BUILDMSG=Stop. BUILDROOT=C:\WINCE700\platform\raspi2 CLEANBUILD=1 NOLINK=1 NOPASS0=1 failed - rc = 2. {log="C:\WINCE700\build.log(33779)"}
BLDDEMO: ERROR: There were errors building CEBASE. {log="C:\WINCE700\build.log(33819)"}

I have looked but not found the project kernel.h can help me?
thank you
Nov 29, 2014 at 10:43 AM
i solved installing shared components

thnks
Mar 9, 2015 at 9:23 PM
Hi,

I have the same issue when I compile the project.
Could you share how you solved this problem?

Thanks.