Building image

Nov 18, 2013 at 10:39 PM
Edited Nov 20, 2013 at 10:43 PM

First of all, I'm here to write about how awesome your project is! Finally someone who has the guts to start building a BSP for the Raspberry Pi!

Then, I prepped my computer for 48 hours with all the software needed: VS2008, SP1, and WinCE Compact 7... I bumped into an issue, very simple to solve, and that's why I'm writing here:

I had an issue while building the solution: it coudn't find some kernel.h file while building the KITL part... Fiddled for some time to find out the answer is actually pretty simple! Just make sure you install the "Shared Source" component, with the latest updates! (Wave 1)

Anyway, can't wait to see some kind of basic USB support, to fully use the Pi as a stand-alone, Windows CE computer!
Nov 20, 2013 at 5:22 PM
Can you please share the shared source component. Can't download it cuz it's greyed out.
Nov 20, 2013 at 9:52 PM
Have you tried installing all the available updates? I got it greyed out aswell, sliding it to the last one made it appear again. Or it may be because you're using an Eval copy of WinCE, I've heard some files are unavailable (I'm using the full student version from Dreamspark)...

(Here's the file anyway, I hope it'll help you:
Nov 21, 2013 at 4:13 PM
Thx... It is the one I need but now it saying that The product key must be a retail version.... aarrrrgh.
Dec 2, 2013 at 5:07 AM
Thank you very much to ideeman1994 for initiated this project.

I try to use evaluation environment of PB, seem to have a same problem on lack of some shared resources.
Also, installing shared resources from installer unable to complete due to retail key.

Looking forward if there are anyway to use eval. env. to complete the building,
so I might prove something before have a budget to buy a retail version.

Thank you again for this good project. ^_____^
Jan 3, 2014 at 3:46 PM
i hope the creator is trying out the Driver package i supplied him for the USB and lan support SMSC is the manufacter of the controller for both of them its a singel chip instance on the board mainly chosen to spare roam on the board for the SoC if its wanted i can find it back on my external drive and hope i can sahre it with all of you but i hope to hear form the creator soon and i hope when i pput the drivers in the bsp he wil put it up hare eventualy
May 1, 2014 at 9:47 AM
I am getting my hands on my own rasberry pi one of these days and then i am hoping to give this project some new life, i am gooing to try and build an embedded compact 7 iamge with the driver package i have for the controller tht controls usb and lan as well in a prefious efford i coudent get the to function correctly it was ether lan that worked or 1 usb port not both usb ports and lan together.

My plan is to investigate why the drivers doesn't tell the chip to enable the all when system is booting.

also i am trying to create an embeded 8 standard image als some personal side project with the hopes that embedded 8 standard has the driver for the controller in its base driver set.
Sep 14, 2014 at 7:36 PM
in my opinion this project died months ago and with it my interst in the resberry with windows mainly due to the fact i cant write drivers and ny first tought for usb and lan was incorrect smsc delivers the 100mb/s lan driver but that in the driver way is an usb lan adapter thats connected to the 3rd usb port of the usb contraller thats a DesignWare Hi-Speed USB On-the-Go Controller.

i cant write drivers so i cant fix it if one of you can just search for the above mentiond controller and try to fix it